SEARCH SCALEAUTOMAG.COM

Enter keywords or a search phrase below:

revell turbo capri

1586 views
6 replies
1 rating 2 rating 3 rating 4 rating 5 rating
  • Member since
    November, 2006
  • From: central wisconsin
revell turbo capri
Posted by railroad on Tuesday, August 04, 2015 3:06 PM

hello. i built this revell turbo capri as a replica for an old 1983 capri rs i used to own. the only difference is that the kit has a straight window in the rear hatch and my '83 had more of a bubble window. the painted the kit testors red with flat red interior. i put rims on off the amt/ertl 1987 mustang. i put a 289 out of a revell 1965 shelby for now because i was out of 302 motors. it was a good substitute because they don't look all that different anyways. if anyone notices the lines on the roof where the wherer the sun roof was on the original kit, i left it there on purpose. i had a sun roof on my '83, but someone broke it out to unlock my doors instead of breaking the door window to steal my radio and speaker box. i didn't ever notice it for 3-4 days. my brother'in-law and fabricated up some sheet metal to replace the glass so i could still have a sun roof. i'm gonna go back later to black out the lines. the sharpie i usually use died so i need to get another one and finish it.

 photo 1438546166.jpg

 photo 1438546785.jpg

 photo 1438546826.jpg

Randy
  • Member since
    January, 2005
  • From: Cape Coral Florida
Posted by BigTallDad on Tuesday, August 04, 2015 3:36 PM

Nice work.

Is it just me or are the photos on the original post square (causing the image to be squeezed and distorted)? If I click on the image, it appears "normal" and is rectangular; same thing holds true for the images shown in the reply...they too are rectangular.

"In order to teach a dog, you must first be smarter than the dog" P.R. Ferguson

  • Member since
    November, 2006
  • From: central wisconsin
Posted by railroad on Tuesday, August 04, 2015 4:14 PM

BigTallDad

Nice work.

Is it just me or are the photos on the original post square (causing the image to be squeezed and distorted)? If I click on the image, it appears "normal" and is rectangular; same thing holds true for the images shown in the reply...they too are rectangular.

 

BigTallDad

Nice work.

Is it just me or are the photos on the original post square (causing the image to be squeezed and distorted)? If I click on the image, it appears "normal" and is rectangular; same thing holds true for the images shown in the reply...they too are rectangular.

 

thanks for the reply. i don't know what is going on with my pics. all my last couple posts are turning out that way. i just got a new computer and i don't don't know if that is the problem or if the new way i am emailing photos to my photobucket is the problem. i need to try to figure it out. anyways, thanks again for your reply.

Randy
  • Member since
    December, 2005
  • From: Upstate New York
Posted by spencer1984 on Tuesday, August 04, 2015 9:10 PM

It looks like the pictures are OK, but they're being distorted in the forum.  When you add the pics to your post, are you leaving the "Dimensions" fields blank or are you filling them in as well?

  • Member since
    November, 2006
  • From: central wisconsin
Posted by railroad on Wednesday, August 05, 2015 12:07 PM

spencer1984

It looks like the pictures are OK, but they're being distorted in the forum.  When you add the pics to your post, are you leaving the "Dimensions" fields blank or are you filling them in as well?

 

thanks for the reply. i'm not sure what you mean by leaving the dimension field black or filling them in. i am just copying the pic from my photobucket page and pasting them to my post like i have been doing for years? i'm clueless on what is going wrong. i have about 5-6 more posts of the models that i have built over the winter and didn't have a computer to email the pics of my camera's sim card.

Randy
  • Member since
    December, 2005
  • From: Upstate New York
Posted by spencer1984 on Wednesday, August 05, 2015 7:16 PM

When you add a picture, you should be getting this window:

The bottom two field, where it says "Dimensions," should be left blank so that the forum can automatically resize it.

  • Member since
    May, 2018
Posted by LindaRaggs on Friday, May 25, 2018 10:29 AM

Is that true wow that is really amazing man? You have done very good job by building this revel turbo Capri. I was really impressed by your hard work and want to appreciate you. Please post in ninja essays blog so the other members also can have a look at your wonderful work and give their comments.

JOIN OUR COMMUNITY!

Our community is FREE to join. To participate you must either login or register for an account.

SEARCH FORUMS

FREE MONTHLY NEWSLETTER
By signing up you may also receive reader surveys and occasional special offers. We do not sell, rent or trade our email lists. View our privacy policy